• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root noob root problem

ran ace hack kit and got message main version is older. update fail! Press power to reboot. what did i miss?

Android 2.3.5

HTC sense 3.0


did you do this prior to running the aahk?

there is no temp root available for the build that your on,so doing the above is required for the aahk to work. this is pretty well stated on their website,so make sure youve read that,and the effin manual pretty thuroughly,as they are not very tolerant of mistakes made from lack of preparation on the irc channel ;)
  • Like
Reactions: estiteler
Upvote 0
I found those instructions after an attempt at running the kit. Now when I boot the phone into hboot it just starts and finishes the same way with the same message. Unable to follow directions any further because of it.

I'm not sure wat you mean by " it just starts and finishes the same way with the same message. Unable to follow directions any further because of it"

You're going to need to be a lil more specific as to what steps you've done,what the responses were,and what error messages you're getting :)

Edit: if you're refering to the main version older error,you'll just need to remove pd98img from your SD card.
  • Like
Reactions: estiteler
Upvote 0
removed file and tried a second attempt following the instructions in preperation of using tha aahk hack kit. was succesfull untill this step,

-check the md5 sum of the boot image:
md5sums boot.img

it should spit back the number on the text document( 17f725c2b78e35b3a053f88b9d1d7ca3 ). if this number does not match,DO NOT PROCEDE. redownload the att boot zip file and try again. if the number matches,then procede.

in the cmd screen i recieved this message

unable to read file/directory boot.img

where did i mess up?
i unzipped file and moved it to the mini adb file as instructed
currently still hooked up to the to pc and in hboot (relocked) now.

please help
Upvote 0
Did you move the entire folder into miniadb? What you need to do is pull the boot image out of the download,and put that into mini adb. The error your getting indicates that the file you're trying to md5 sum,is NOT inside the same directory as the utility.

In other words,if the boot image is inside a folder,inside mini adb, the md5 sum utility cannot find it.
Upvote 0
i have the miniadb folder on the desk top, when i select it a windoe comes up with what is in that folder and it shows 1 item in the folder "boot" with no folder next to it. still same message unable to read. i have gotten all the other files placed without a problem. i dont know wat i am doing wrong
Upvote 0
i cant win. tried to flash the image and now "signature verify fail" message.

if the following is still the case,this is your prollem:
currently still hooked up to the to pc and in hboot (relocked) now.

your bootloader needs to be unlocked to flash the special boot image. re-unlock it and try again :)

dont worry,youll get it :)
Upvote 0
unfortunately,just being rooted will not enable you to use a carrier provided service without paying for it. there are 3rd party tether apps that will allow you to use your phone as a hotspot,but i cannot really help you here.

some forum searching,and info from other members should help you find what you need :)

certain roms may include a tether app,but you wont need to change the rom in order to use 3rd party apps. you should be able to make them work on stock.

glad the aahk went without a hitch,you may to upgrade back up to the att 3.0 rom now that youre s off and supercided from the aahk. you dont really want to stay on the older,downgrade rom and firmware. :)

you can use directions here to upgrade and re-root: http://androidforums.com/inspire-4g-all-things-root/632116-firmware-update-rooted-inspire-4g.html
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.