• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help "Notification sound" list doesn't play the sounds when they're selected

Adi Inbar

Oct 20, 2014
I'm setting up a new Galaxy S9 running Android 10. When I go to Settings > Sounds and vibration > Notification sound, it doesn't play each sound when I select it from the list.

If I go to Sounds and vibration > Ringtone, each time I select the radio button next to any item in the list, it starts playing that ringtone, just as it has always worked on other Android devices I've had, but in the Notification sound list, when I tap a radio button to select a new sound, it stays silent.

The device does play the selected notification sound when I actually get notifications. Also, I am able to change the notification sound, i.e. if I select a new sound from the Notification sound list, I do hear that new sound the next time I get a notification. The only problem is that while I'm selecting a notification sound from the list, it doesn't play each sound as I select it with the radio button next to it so I can hear what it sounds like.

Similarly, when I go to Sounds and vibration > Volume, if I move the slider for Ringtone, it starts playing the currently selected ringtone at the designated volume, so I can hear how loud it is, the way it has always worked on other devices, but when I move the sliders for Notifications, Media, and System, it stays silent. Again, it does change the volume for all of those sound channels, I just can't hear a sample while I'm moving the slider. For the Media and System volume sliders, this is consistent with the behavior of other devices I've had, but for Notifications, it has always played a sample when I moved the volume slider, just as it does for Ringtone volume.

(I did try wiping the cache partition, it didn't help)
Last edited:
have you tried rebooting the phone?

Of course. You can't wipe the cache partition without rebooting to recovery.

did this just start happening? or has this been an on going issue? was it after an update?

As I said, I'm setting up a new phone. This didn't "start" happening after working, that's how it is as I'm trying to get it configured. It came with Pie and I installed some security update and the upgrade to Android 10. I have no idea how it was before that, I installed the updates before I started configuring anything.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.