• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

phone doesn't always automatically exit do not disturb modes as scheduled

This is my second LG Velvet (warranty) that does this. It will enter DND mode as scheduled but randomly doesn't exit dnd about half the time.
you can try a factory reset. but if that does not work, than i do not know what else you can do other than to either get used to it or try a different phone. don't expect much from LG though as they are not making phones any more.
 
Upvote 0
You should be able to put a DND quick settings tile in your pull down menu.

This will allow quick access, but itbwill be manual.

You can also try restarting the device- before you try doing a reset- to see if that resolves the issue.

If that works, keep in mind that it is probably a temporary fix.

Manual control is probably the foolproof fix.
 
  • Like
Reactions: mikedt and ocnbrze
Upvote 0
Thanks for the info folks. I've tried restarting and resetting to no avail. I've also tried safe mode and that also did not help. BTW it is running android 11 with current updates. I wish I knew that LG was getting out of the phone business, if so I'd have purchased a different phone. Oh well, hindsight is 20/20...
have you tried a hard reset instead of a factory reset?

if not then here is how to do it:
https://www.hardreset.info/devices/lg/lg-velvet/

keep in mind that this will trip FRP(factory reset protection) this means that you will need the google acct info first used to set the device up.......so make sure you know those details before doing so. otherwise you will have extreme difficulties getting into the phone after the hard reset is done.
 
Upvote 0
I've found a work around! Last night I noticed that there is a setting in do not disturb mode to end if alarm rings. So I enabled it. Then I created an alarm for the desired time with all the notifications and sounds turned off. This morning the alarm quietly went off and dismissed itself after a few minutes. Afterwards DND had been turned off. So it appears to have worked, I just hope it wasn't a one time thing. It may just be a workaround but if it works I can live with it. I'll update in about a week as to it's success. Fingers crossed.
 
Upvote 0
I don't foresee a problem with notifications since they are only turned off for that particular alarm. But just in case it is, I checked into the settings to see if I could record a personalized alarm sound and it turns out that that option isn't available on my phone. However I did notice that there is the ability to adjust the volume for each separate alarm, which can be set all the way down to zero. I figure that should achieve the same intended result if these current settings don't work the way I want. Only time will tell. Thank you for the suggestion though, I do appreciate the input.
 
  • Like
Reactions: ocnbrze
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones