• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Problem gaining some root permissions? ??


Sep 4, 2010
Hey guys, having some problems with my liberty 1.5 rom I downloaded last night. I am rooted obviously with z4 root. I have some SU permissions dx bootstrap is allowed rom manager and titanium backup all gain super user permission. Wireless teather and DX overclock will not even ask for root rights it just says my device is not rooted. Worked fine when I was running apex and as well when I downloaded liberty without doing a data wipe /factory reset. However when I did that and started from scratch I couldn't get into DX overclock by can gain permissions for some root programs. Have done a battery pull and unroot/re root. Nothing works to gain permissions for DX overclock
Thank you
Yes, I have uninstalled droid overclock multiple times then re-installing it. I also have SetCPU(dont ask why) and that will not gain root access either. Same thing goes for wireless teather, uninstalled and re-installed from the market and still says "unable to start teathering is your device rooted?" This is very strange because the SU box never appears asking me for root rights? However i can get into Titanium backup, bootstrap, and rom manager no problem...
Upvote 0
Okay maybe I am not able to use z4 root anymore? However i downloaded a "root checker" and it says i do not have root permissions. I also get the $ sign in the Terminal Emulator and says SU denied.

When i go int SUPERUSER it says bootstrap, rom manager and titanium backup are all acceptable applications that are running fine. This is what i do not understand. How do i have root privileges for these applications but not for overclock/it says on the root checker i do not have privileges?
Upvote 0
Please delete thread, Everything has been resolved. I did multiple uninstalls combined with battery pulls on z4 root and it eventually worked. Also force stopped super user in my applications menu(for people having problems with this who are searching google as i was)

no reason to delete. this may be helpful to someone else. ;)
Upvote 0
I had an odd issue with Liberty 1.5... Before installing, I had done a system wipe as recommended and all seemed great. But at some point I seemed to had lost root (su in terminal gave me access denied, and certain apps said I didn't have root access), but still had the superuser app. Apps like bootstrap and droid o/c that had already been given su permissions and were listed in the su app still worked like normal. I tried uninstalling the nonworking apps and re-installing, tried re-rooting with z4root several times, tried booting into recovery and wiping cache, nothing worked. Last thing I tried was booting into recovery, doing a factory reset and re-installed Liberty 1.5 and let google re-install my apps for me rather than using TiBU. That finally worked and gave me back my su access for all needed apps. Hope this might help someone...
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.