• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Problem with rooting


Android Enthusiast
Jun 29, 2010
So, I got my Fascinate in the mail today and one of the first things I wanted to do was root it using the 1 click method. I downloaded the Samsung drivers and on one computer, it wouldn't install the drivers so I switched to another computer. On this one, the drivers installed, but it does not recognize my Fascinate being connected to the computer. I click on the Run Root file and get a "Error, no device attached" error message. It doesn't even recognize it when I turn usb mode on to try and move files from my computer to my phone.

I tried unmounting the sd card, power down, power back on and reinsert sd card idea that I've seen several suggest, but it still doesn't work. I'm using the usb cable that came with the phone also. Is there something I could be missing?


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.