• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Rooted, unlocked 'Error while searching for networks' on new provider


May 16, 2012
I've been using my rooted Desire (running Redux) happily on orange for some time.

I've tried to move to a Giff-gaff contract, and so I bought an unlock code from htccode.com.

When I put my new SIM in, it unlocks fine, but then fails to find any networks, just giving a 'Error while searching for networks.' message.

I've also tried it with the O2 SIM from my work phone, and it give the same error, so I don't think it's anything to do with Giff-gaff themselves necessarily.

Any thoughts? It's driving me crazy. I've ported my number over from Orange, so now can't use the phone at all.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.