• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root rooting exploit (tried it list)

update: i went with this post and it did not work for be. it does state to use it before trying kingofroot.
by trying to install adb from another site and from the android SDK both failed.
one of them includes the 15 second adb with fastboot installer.

i also noticed that if you select install drivers from the phone when you plug it in to the PC it contains ADB install uninstall.
they currently dont work for me. either because it is windows 10 that i am using (64bit) or because of the previous installs.

ill keep searching and updating.
Upvote 0
Haven't tried anything else so far.
Is anyone else trying to root the phone?

Note: I would also like to point out that the phone allows me to unlock the bootloaders from the developers option menu.

I am looking into how this can help me root the phone.

it isn't needed to root the phone
But seems like we have the ability to install custom roms available to us?
Still would prefer root.
But for now I'm gonna try and make a debloated ROM for myself.
Last edited:
Upvote 0
Thanks for starting this, I just picked up mine today. So far framaroot and poot have failed. Kingroot failed too but according to the jrummy root check it seems to have installed busybox.

I'm going to try a few other things tonight for a no PC root. If that fails I'll push twrp and flash su. But it'll probably take a while to get around to pulling out the laptop.
Last edited:
Upvote 0
TWRP has nothibg for it on their site
Yeah I caught that, CWM doesn't either (wasn't surprised there), I thought about pushing the one ZTE build that TWRP has but without a backup of the stock recovery... I don't want to stretch my luck. I'm also having issues updating ADB on my laptop for ADB sideload via stock recovery.

Does anyone know if there is a download mode? FTM doesn't open it up for ADB. I can access /system/bin/ via shell but can't yet write to it or change permissions so no real strides there.
Upvote 0
Do you know of any exploits that use that (any newer device preferred)? I hit a wall with the Adb version. If anyone knows where to get the newest version it'd be helpful.

not as of now, there were a few more findings i got. but i hit the same wall (presumably) with ADB as well, for me it doesnt even open. what ADB are you working with?

Been thinhking of buying this, but not til a root is availible. anyone tried SuperSU?

SuperSU is a root manager, i dont think it will root your phone for you. kinda like superuser.
Upvote 0
so, i am trying to find the website where i got it from, which im sure was the zte website, IM positive of it.
i was able to download this marshmallow kernel from the site. i remember it being the only thing there.

well i didnt post it up because i didnt have time, and i wasnt sure if anyone else had made this discovery but i did upload it to dropbox for safekeep.

heres the link
name of the file is: N9519_Marshmallow_kernel(3.10.49).tar.gz

Update: i still dont remember how i stumbled upon it. tried backtracking my google searches.

UPDATE 2: looks like i had placed the site on a different thread.
heres the site
Last edited:
Upvote 0
I don't recall the version number but the format was x.y.z and z was one digit below what was required to push to the device. I did try via command line (win 7 and Ubuntu 12) and via Odin (win 7). It's been a while since I've tried anything new.

As for escorts question superuser /supersu do not root a device and do not have the binaries needed for root access. But this is a great low price phone, I switched to a Samsung J7 for about a month and ended up switching back to this device. It works well without root.
Upvote 0
BTW: the kernel is available on ztedevice.com which made me think, has anyone tried asking ZTE for help or instructions? Might sound odd but it works for HTC.
havent tried that, it would be nice. everyone seems to be holding back on this phone just because of root.
it gets the job done without it. but i like to tinker with my toys.
Upvote 0
Has anyone been able to get a pc to rexognize the phone when its in stock bootloader mode nothing i try seems to work i know that the bootloader is locked by boost mobile but u would think the pc would still at least see a device is pluged in to the usb port
i was actually able to unlock the bootloader from the developer settings. have you tried that yet?
but how would you normally get a pc to recognize a bootloader? I have never done this.

UPDATE: i also started this thread a while back.
Last edited:
Upvote 0
Kingo root works if u use PC version and it's only temp

Yea use Kongo root the newest version requires a PC

I've used kingroot before, but never kingo root. I saw before that kingo uses its own su app, like King. How intrusive is it and how well does it run? Also is there anything else installed (like Purify in kingroot)? One last thing, I know there are a few apps you can use after king root to remove its su and purify and install your preferred su app, does kingo have similar?

I'm likely to try anyway, but I'd like to know from someone who's tried it before.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.