• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Royal Screwup Can NOT UnRoot!

I seriously messed up.

I can't unroot my hero cdma. Why would I want to, you ask?
Because I did an upgrade for my phone, then switched it to the Missus's phone number (she gets the new Galaxy). Now my phone can't connect beyond regular talk & text. Poor hero! I tried HROOT and got the error 131.

I've done searches, no luck.

Please Help this dangerous man with little knowledge.

What Rom are you on, you may have to flash a Sense Rom, then you will be able to run the RUU again, my guess is you are not on a sense Rom, also try putting everything you have on SD card in a folder to your PC for back up, then format your SD card and then transfer all back and try to run the RUU again see if it works this time.

Yeah, I tried the RUU + htc sync. I tried the HERCIMG.zip.

Man, what a half-smart, total fool I am! Currently trying to figure out what lessons to learn from this fiasco.

Thanks, LBPHeretic. You're good people. I loved my smart, little hero!
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.