• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

S - i recently tried rooting my A20S it wasnt sucessful

The simplest fix is probably to reflash the phone back to stock firmware. You can download this from Sammobile.com, and I'm sure there are flashing instructions there (I don't have a Samsung phone so haven't learned the process myself). That will overwrite whatever you did wrong. You will need the full model number (not just A20s) to ensure you get exactly the write firmware.

If you want more specific help you'll have to tell us exactly what you did and what you saw when you did it, so someone can try to figure out what went wrong and whether there is a solution other than reflashing. Right now all we know is that you tried rooting by an unspecified method and something went wrong, which isn't much to go on. Also you would need to tell us what you actually did, not which recipe you followed (because if you didn't follow it correctly pointing us to the recipe won't tell us what you did wrong). But to be honest unless you took a backup using a custom recovery before you tried to actually root the answer is likely to be "reflash the device" anyway.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.