• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

S2 not working completely!! :(


Dec 11, 2013
So I was copying pictures from my s2 to my computer from the facebook folder. So suddenly it said something like it is copy right protected or read protected. So I was able to copy half and unable to copy the rest.

I tried again, and the error still appeared on the rest of the images which were not able to be copied. I kept pressed and held space-bar button to apply "Skip" on copying the files to get as many files as copied just in case.

So after that, I picked up my phone, hit the power button to turn the screen to check the files in that folder, and the screen didn't turn on. I pressed many times but it still didn't turn on.

I removed the connected usb and the battery, put the battery back to turn on and still didn't work. Tried with my uncle's fully charged S2 battery, still didn't work.

I pressed and held the "Vol+, home & power" buttons to go into the recovery mode, still nothing on screen. It's like a dead device. I watched couple of videos about the small JIG usb thingy to fix the phone but I am not sure if it will work or my data will be recovered. I just want pics from the app installed called "Vaulty"

But anyways, is there any fix for this issue?

Oh and the phone does heat up if I connect PC cable or charger. But it doesn't charge. And my phone used to heat up on use.

Also I am on ICS Unrooted phone. Please help!


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.