• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Samsung XCover2 weird problem

Henry2022

Lurker
Jan 6, 2022
4
0
Anyone knows this problem?
Phone has worked flawlessly before. After recharging & startup shows this (see pic) seems factory reseted, everything wiped, asks for software update, weird tech spec reading comes up. No Internet connection (although SIM card OK and I also got a new one to be sure), but I can connect to a network so phone seems to work. Tried also factory reset, no difference, same startup.
In factory reset, it says:
E: failed to mount /efs (invalid argument)
Also noted: SAMSUNG-logo stays much longer
 

Attachments

  • Pic.jpg
    Pic.jpg
    149 KB · Views: 134
Appreciated. I could try that stock ROM reflash if it's otherwise dead anyway, rather than just buy a new one.
You know if it's a easy process?
do you have usb debugging enabled? if so you can try flashing a firmware update. you can get the firmware here:https://www.sammobile.com/firmwares/

instructions on how to flash the firmware will on the site.
 
Upvote 0
Last edited:
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones