• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root SBF problem

cougar214

Android Expert
Feb 9, 2011
1,422
157
O'k, So I was trying to put a home replacement app on my phone. It was the spb 3d shell. I'm sure you guys have heard of it. Well needless to say my phone DID NOT like it and I was forced to flash a backup I made before hand.

Smart thing to do but my backup isn't working. I went through all the motions of trying to clear data/cache etc. Nothing is working. So now I'm forced to SBF back to stock using RSDlite. The problem however is RSDlite isn't working for some reason. I did this process once without a problem but it was awhile ago.

When I try to flash the file it won't flash and when I go into the error log in RSDlite I get this error,


14:21:50, May 26, 2011
Line: 900
ERROR: The file selected is an invalid superfile.
Please enter in a valid superfile.
File: D:\GitProjects\hdt_windows_flash\flash\code\flashdll\PST_FP_FlashFileIO.cpp

14:21:50, May 26, 2011
Line: 1761
ERROR: Error validating image files.
File: D:\GitProjects\hdt_windows_flash\flash\code\flashdll\PST_FP_Flash.cpp
Device ID: 0


This is strange to me because I gave up(for a bit) on trying to make my own themes till I get a better understanding of it so I removed everything I needed to do it with, including Git. Is there something I need to remove in the environmental settings?

Just so you know I know I need to rename the SBF file because i'm running windows 7 ultimate 64 bit. Which renaming is a PITA! because it's a crap shoot. You have to keep renaming till you find the right file name that RSDlite will except.

When I load the file into RSDlite the file comes up with only half the file info and when i try to flash I get the error 0x07100 failed to flash. I tried moving the SBF file around to different folders, nothing. I'm lost guys. I don't know what to do. The first time I did this it went off without a hitch. I don't know how to handle this. Any ideas?

EDIT: I managed to get an older backup to work. I don't know why it worked but I'm not gonna look a gift horse in the mouth...lol. But this SBF problem still remains and I would still like to solve it somehow in the event SBF'ing is my only option.

EDIT2: Metfanant, Steven, bouchigo. Come on guys, I know you're out there. Come help me out....lol.
 
With the SBF issue, did you manually remove GIT or did you uninstall it? Also, do you have the Android SDK installed (not that you should really need it, but it does install the latest USB drivers, so that might help bit).

Sorry, never had GIT so I don't know if it is a .ZIP package that you simply extract or if it is an installable package.
 
Upvote 0
Honestly, I don't remember how I uninstalled Git. I think I uninstalled it like normal through add/remove. I think the main problem was finding the right file for the SBF. I got my hands on a full 2.3.340 SBF file that is 434 megs.

I dropped that file into RSDlite 4.8 and it picked it up with no problem. I'm thinking people always throwing these SBF files up as .zips is what is causing the issue. I could be wrong but like I said, this full SBF file I just got was picked up by RSDlite with no problem.

I did the bouncing around thing also with the usb drivers from one version to the next and I have the latest driver in right now without headaches. I fell so ashamed of myself. Coming on this forum to offer advice to others when I can't even get my own stuff working properly.

I guess that's what I get for not doing things to my phone enough to get every process down pat....lol. But in all fairness I never have to. Everything I do to my phone, SBF, flashing roms, themes, etc, I make sure I follow the directions precisely and only have to do things once. Maybe I should screw up more so I get more experience?....lmao.
 
Upvote 0
No worries, dude - happens. I've pulled a few things myself that I later thought "WTF? I should have known that!" before as well.

As for screwing up - well, that's how I've learned almost all of the troubleshooting and repair stuff I know when dealing with computers and gadgets, so.... :p

Glad you're back up and running again. I probably would not have thought to check the file itself for at least another several steps lol
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones