• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Sdk emulator not working : VCRUNTIME140.dll not found

So I installed Android Studio not long ago. I installed everything right, I installed in the sdk tools :
  • Android Emulator
  • Android SDK platform tools
  • Intel (x86) Emulator accelerator (HAXM)
I installed the API-Level 30 (x86 too)
I tried enabling/disabling launching in a tool window
I uninstalled and reinstalled everything several time

Next, I tried launching the emulator with command line
I first created an AVD: Pixel_XL_API_30 and used the command
emulator.exe -avd Pixel_XL_API_30 in the right folder with admin and non-admin privileges
I get a VCRUNTIME140.dll not found

So I tried fixing the dll following mainly (https://softwarekeep.com/help-center/how-to-fix-the-vcruntime140dll-is-missing-error-on-windows-10)
I ran scannow, I tried repair tools in all Visual studio version I could find in apps and functionalities
Then I tried unrergistering and registering back the dll and I get the following :

Module VCRUNTIME140.dll was loaded but entry point dllRegisterServer not found (more or less) Same for dllUnregisterServer.

And here I am stuck and desperately in need of your help. Thanks


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.