• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

[Solved] XT-2115DL Moto Stylus drops usb connection when file transfer initiated

Not rooted, runs Android 11. When connected to PC (tested on ubuntu 20.014 and windows 10) set in preferences to "file transfer." "USB controlled by" setting remains on "this device," fails if attempt to switch to "connected device."

Connected device succeeds at mounting phone, and can freely navigate the filesystem remotely. However, nearly any attempt copy a file of significant size (i.e. > 1MB) from the filesystem to the connected device freezes at about 2% completion, then ends in an error. In linux this is "libmtp error: Could not get file from device." The same occurs if the device is unmounted and an adb pull is called in terminal: hangs nearly immediately and eventually fails. This doesn't happen the other direction: files from the connected device transfer successful (and quickly) to the phone filesystem.

After the error occurs in mtp, the phone filesystem is no longer browsable from the connected device, and attempting to unmount it results in "device busy" and it takes a few minutes to unmount. When remounted it is browsable again, but file copy attempts have the same result.

This occurs on different machines, and different phones transfer files correctly with those machines. This phone is new but was working properly yesterday. There is no visible damage to the phone or usb-c cable, both of which are new or nearly new. So the problem narrows down to software on the phone conflicting with the transfer.

What could that be? Which apps could do this, or result in it if disabled/depermissioned?
Last edited:
as I mentioned, operations in file browsers with the phone mounted, and using adb with it unmounted, both produce the same result.

The fact files still copy TO the phone makes me suspect the cable is too long, I'll check what happens with a shorter cable. usb-C ap[parently has to be pretty short to work reliably, 1m or less
Upvote 0
Well if all else fails you can always transfer files wirelessly using Solid explorer, which is what I use on a daily basis. Movies, documents, mp3 files all transfer with no issues.
  • Like
Reactions: ocnbrze
Upvote 0
It's not about how fast the current goes, but how much current there is. Twice the length of a given wire has twice the resistance. So for a given voltage (V = IR) the higher resistance results in lower current.

I would guess it only happens upstream because the phone's power supply is much weaker than a desktop pc's. In any case the .9m cords work perfectly (the old one was 3m)
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.