• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help "Sorry, weather currently unavailable"

ICS stock weather widget works less than half the time for me (I see others on xda developers forums and other places have also had this difficulty) and it is not related to a malfunction with location services. Perhaps it's not even ICS- or SGN-specific, as it is being discussed here as well
Weather unavailable in "News and Weather" app? - Android Forums


Happens to me at least once a day, but a tap on it clears it up. I've not tried another widget that does something similar. Not sure if Beautiful Widgets or any of that stuff works properly. I think there is probably a FAR more attractive alternative. Overall it isn't a big deal to me. Like I said, I tap it and it works again.

I pretty much expect everything that worked on my Thunderbolt to not work on this phone. This is just some of the growing pains that we face as early adopters.
  • Like
Reactions: theWUbear
Upvote 0
I noticed this also. But i thought it was my "network extender". I have two. One for work and one for home. And they always cause it to come up with the wrong location.

So instead of "Detect my location" I typed in my zip code and it seems to be better. But you guys are saying it's getting better anyway's. I'm going to check "detect my location" again and see what happens.

Edit: just tried it and it couldn't 'set my location'. So i went back to typing in my zip code. It has been solid for days this way
Upvote 0
i am also having the same isssue..
its saying "weather currently unavailable"
and when i select to "detect my location" works but i cannot enable gps and drain my battery when i will be in this city ....
i canot enter my location manully it wont accept it when i enter it says
"sorry couldn't find location matching xxx" where xxx is any city that in enter.. i tried entering postal code/zip code still the same issue.. earlier manually setting the location by typing the city name was working i had manually enterd the city and was having no issue.. i am having this issue since past few days.. have tried reboots.. no solution. have force closed the weather app and cleared its data but still the same issue... any solution ?

setting to
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.