• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Storage space says full after TWRP flash fail and firmware reinstall

Hi everyone,

I recently installed LineageOS 17.1 on my Xiaomi phone. I’m not super experienced in these things but I was able to follow the instructions fine and it went very smoothly.

Then my fiancé wanted me to install it on his phone too. He has a Samsung Galaxy J4+. I started following the instructions found here: https://www.getdroidtips.com/lineage-os-17-1-galaxy-j4-plus/

I ran into an issue when trying to flash TWRP – basically the phone got stuck in boot loop and an error appearing saying “Recovery is not Seandroid Enforcing”.

I couldn’t find much help online to fix this error within this specific context and was anxious about it not being my phone, so I just flashed the latest firmware for his phone model and did a fresh Android 9 install. That worked fine.

However, now we have a strange issue – When he tries to take photos it tells him there is not enough storage space and the storage information says he has over 7GB of 8GB, and most of it is listed as ‘other’, so I’m not sure where it is coming from.

He says he never had problems with storage space before (although I thought 8GB seems quite small). So something seems to have caused this from my tinkering, something hasn’t been removed from the cache maybe?

We are both aware that I’m an amateur and there was a risk of something going wrong so it’s not a massive issue, as we can buy an SD card for external storage etc, but I just thought I would try and ask on here to see if anyone could shed light on why this might have occurred and if it can be easily fixed.

Thanks so much!!
You are right: 8GB is tiny for any phone. But since the J4+ was supposed to have at least 16GB (which is also criminally small for a 2018 handset) I have to guess that this is just showing the part of the storage that is not used by the phone's system itself. But that is unusual actually: most phones show the full capacity of the device, including the space used by the system (which in some devices is classified as "other"), so 8GB on a 16GB (or larger) device is very strange. Can you post a screenshot?

The trouble with "other" is that it's a useless classification. All it means is "this doesn't fall into the few categories we've listed here", so it can be almost anything. If you can still install apps, maybe try something like DiskUsage to get a better view of what is actually using the space?
  • Like
Reactions: ocnbrze
Upvote 0
Yeah, I thought it seemed very small!

Okay, I've attached a screenshot of both the default internal storage view and also what the DiskUsage app shows. Not a whole lot of info really:
Screenshot_20210413-194132_My Files.jpg

Thank you!!
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.