• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root SU prompt for app doesn't allow me to press "Grant"

Status
Not open for further replies.

crackface

Member
Jan 18, 2010
59
4
Hi -

I'm a new T700 user. Got it home and immediately rooted it via instructions here:
http://forum.xda-developers.com/gal...icial-chainfire-cf-auto-root-sm-t700-t2960171

That seemed to have worked fine. I booted to recovery, and the only issue then was it was erroring when trying to load 2 different ROMs I was trying. See here for my post showing the error message if that matters:
http://forum.xda-developers.com/galaxy-tab-s/help/8-5-to-recovery-error-installing-image-t3010758

Someone recommended using TWRP, so I installed that, and my ROM load worked like a charm.

So now I have the Cyanogenmod 11 for SM-T700 ROM loaded, and everything appeared to work fine until I went to install an app that needed root. It would prompt Deny/Grant, but would not let me press the Grant button, only the Deny. I then looked for SU in my app drawer, and I found none. I tried installing one of them from the playstore (not sure exactly which, but it was the blue "#"), but that didn't do the trick. I then figured I'd try rerooting (took nandroid backup first) this ROM. It took, but when I rebooted there was still no SU. I tried an app that triggers the SU prompt, and found a dialog box in the background telling me to update SU. I did, and finally I could see SU in my app drawer. I loaded the app that triggers the SU prompt and got a different looking SU prompt, but still would not let me hit the grant button.

I'm not sure what my next step should be here, but I don't know if I've lost root or if something else is going on, anyone have any advice?

Thanks in advance!!!
 
Status
Not open for further replies.

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones