• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help t989d isn't recognised by computer

Hello I'm new here. I'm writing here because of an issue that started two days ago with my Samsung Galaxy S 2 X (SGH-T989d) (Telus version) Her is what happened:

1- On the morning, even if my phone charged all night, I started using it after one hour or so, the battery was almost completely depleted.

2- I plugged it to my wall charger (original) It was like if it was powered by it, but not charging. Then.

3- I plugged it to my laptop (with original cable) charging icon apeared, but battery depleted. during this time "unknown device" thing kept popping on and off on my computer

4- I pluged it to my wall charger (the same than before) and it finally fully charged.

5- Now when I plug my handset to ANY computer (with, without kies or drivers, it doesn't matter) the phone charges, but, nothing apears on the computer (no unknown device or recognizing the two drives of the phone, but not mounting them (as it did before)) on the phone, the "USB" icon doesn't promp and if I go to settings/wireless and network/ USB utilities, when I touch the usb mass storage button, it prompts me to connect cable, which is already connected. USB debug isn't activated

6- When my phone is powered off and I start to charge it, the charging screen doesn't prompts, It just start booting.

My phone was rooted with Blue1k's tutorial: Telus Galaxy S2 (T989D) Ultimate Root and Optimization Guide with Steps - Android Forums

Please, help me.
Thanks in advance!
PS: sorry if my english is sometimes lousy,my first language is french, not english...

edit: now, I sometimes get a "unknown device" prompt at my computer, but still no usb option in the scroll down menu... I've tried to uninstall kies and the drivers, reboot and, then, reinstall kies
Ok here is one question I would like to know and maybe some help!!!

Since you are rooted - Are you just rooted, or did you also flash a custom rom on your phone?

Help for computer problem: I keep saying this and I will say it again I guess make sure you go into your windows update in control panel and verify that you have windows media player updated. It is the windows media player packages and services that carry the phone device driver. It is also refered to MTP and PTP driver. For me my phone was returning an error when I plugged it into my computer because I have a special distribution of windows which did not have windows media player all together and I had to install it myself so check it out.

Also restart your phone and plug it in.

Next for the discharge issue. Please NOTE! I put it in capitals coz it is IMPORTANT - when you put your phone to charge from a USB on your computer it is not able to draw enough electricity (amperage) that the USB provides is much lower than the electrical socket which is why your phone should most notably be plugged in there. Next if you do not have a custom rom and your battery just drains do the following - run your phone until it turns off from lack of battery life where the screen is completely blank. Than grab it and without turning it on put it into the original charger in the electrical socket and charge it to full before turning it on. This should reset the battery - I had similar problems and they were aliviated when I did this. Also go to the market and grab juice defender - there are 3 versions and one of the 3 is free even though the best one is the 5 dollar one. This should help your phone a little bit (this only depends on if you are on the stock rom so all you did with your phone is S-OFF nothing else).
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.