• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Unable to install any apps.


Nov 1, 2010
Hi all,

Looking for some advice please. Currently I am unable to install any apps on my Desire. :thinking:

Apps will download from the market but when I try to install them I get a message simply saying "Application not Installed". I have even tried to install by navigating to the app via astro manager but same result.

I have cleared the Market Cache which made no difference. I have also uninstalled a few apps to see if that would help. I think it may have initially but I have since unistalled a ton of apps but remain unable to install new apps.

Memory wise I have 46mb internal Free and 1.17gb free on the SD card. So memory should not be an issue?

I have an Orange Branded HTC desire running Android 2.2 The phone has not been rooted.

The only thing I have done out of the ordinary is the force move to SD card as detailed below.


The plan is if neccessary to do a Factory reset tonight if I am unable to solve the problem. I'm hoping someone might be able to shed some light on why this is happening so I don't need to go down that route.

Any thoughts/suggestions?

Thank you in advance! :)
Thanks for the quick reply. USB cable in not connected.

Where do I find the auto update tick box your refer to? Is it general setting that will be applied to all apps? If you mean on the market page when you view an app then I've just checked it and it seems to be set as unticked by default.

Tried to download an app double checking update was unticked and same result. App not installed.
Upvote 0
Just a thought, but have you tried rebooting the phone, and then trying to download an app?

Incidentally, 46MB should be miles more than enough to install pretty much any app. I've been able to succeddfully install apps with <15MB free, though some apps start to malfunction (Gmail, for example) at this level.
Upvote 0
Thanks fishyweb. I have tried the reboot without success. I've actually had the battery, memory and sim card all out lol.

It's almost as if it's a permission issue. I thought maybe it was the Micro SD card that was somehow "locked" but I can download an app and I can take pictures both of which are saving to sd card. That blows that theory out the water.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.