• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Uninstall system apps

Hi I've got an HTC Desire original model(Bravo) running android 2.3.7 and I'm trying to uninstall system apps. Man what a pain

First the phone is rooted with SU

I've used the app removing program. Didnt work
I tried Titanium backup which did not work
I tried deleted the system files using a root file browser. Files are read only and I can't delete
I looked in device admistrators to remove the privileges, but no apps were found. I ran hidden device admin detector which found no apps.

Ok How do I get rid of these system apps.
Welcome to our AndroidForums, John :).

1. Do you have a custom recovery installed?

2. Have you taken (and saved-off) a Nandroid backup from said custom recovery?

Doing what you're asking should be fairly straight-forward under Gingerbread, but touching anything system-related is just asking for trouble (soft-bricking, boot-loops) without the ability to restore from a known good backup).

Disabling is a much less invasive and better option than actually removing an app.

That being said, it's likely that you or your tools you were trying to use did not first remount the /system partition in read-write mode first.
Upvote 0
See I want to get these apps to stop using system memory and also free up the space they use up to begin with.

1&2 - No - I used titanium backup

How do I remount the /system parition? I used root explorer verison 2.1(only one I could get to install) and tried an tab that said Mount R/W but it just said delete failed, the file disappeared,but came back after a reboot.
Upvote 0
Oh, I have heard of devices that have a mysterious behavior like this where things that were removed do indeed come back after a reboot. There is apparently a mechanism where files / apps are re-installed (or simply re-copied) on each reboot (it could very well be more than just apps).

Not sure why you would see "delete failed" but the file was indeed gone--that sounds contradictory?

Root Explorer has a "mount /system r-w" mode/function somewhere in it (I can't check for you at the moment, though).

It could be that you cannot permanently remove those system apps... If I were you, I'd Google around and see if you find references to your device and removed system apps coming back--I'm betting you'll find some.

Also, you really are taking a chance monkeying around the /system partition without a Nandroid backup and/or custom recovery safety net...:eek:
Upvote 0
Move To SD Card - Just plain did not run.
What I've done since yesterday is update Titanitum backup and SuperSU. Non whenever I try to uninstall an app using TB it freezes and I can attempt to update binaries, but its goes says updating and after hours has not finished :(

Still having delete failed or it anything does uninstall or delete it comes back.

In general I never rooted it, it was given to me by a guy who said he had rooted it. I've ran a full recovery on the phone since then, but now I'm wanting to remove any app I can figure is not needed to free up memory and stop them using memory. For example adaware and I'd maybe want to replace the stock camera and music player software. It really annoys me simple stuff on a PC is hours/days of effort on a phone.

Re-root huh. Odin? Nope don't have that, but yes a TB backup I have. I'm also close to giving up.
Upvote 0
OP, if you really do have root from the terminal (Android Terminal Emulator or adb shell), then you should be able to remove your items manually.

I still think your issues are likely related to a mismatch su binary /Superuser app pair.

That being said, and with my still warning/caution about doing this without the benefit of a custom recovery / Nandroid backup notwithstanding, I can publish commands that will probably work for you if you'd like.
  • Like
Reactions: ThePhizzle
Upvote 0
It sounds like the version of the su binary you have does not know how to talk properly to the Superuser.apk you have installed--i.e., you're possibly running a newer version of the su binary with an older version of the Superuser.apk--I don't know for sure, but I remember seeing things like this a few years back (i.e., when Gingerbread was still prevalent).

Anyway, here are some example shell commands showing you the framework of how you might do this (you're mileage and details will, of course, vary):

[become root]

shell@hammerhead:/ $ su

[show how the /system partition is currently mounted]

root@hammerhead:/ # mount | grep -i " /system "
/dev/block/platform/msm_sdcc.1/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0

[remount /system in read-write mode]

root@hammerhead:/ # mount -o remount,rw /system

[verify that /system is now mounted in read-write (rw) mode]

root@hammerhead:/ # mount | grep -i " /system "
/dev/block/platform/msm_sdcc.1/by-name/system /system ext4 rw,seclabel,relatime,data=ordered 0 0

[navigate to the desired directory]

root@hammerhead:/ # cd /system/app

[list the file we want to delete]

root@hammerhead:/system/app # ls -ld unwanted-system-app.apk
-rw-r--r-- root root 480757 2009-01-01 03:00 unwanted-system-app.apk

[remove the desired file]

root@hammerhead:/system/app # rm unwanted-system-app.apk

[see that the file is now gone]

root@hammerhead:/system/app # ls -ld unwanted-system-app.apk
unwanted-system-app.apk: No such file or directory
1|root@hammerhead:/system/app #​

Again, you really do run the risk of a boot loop or soft-bricking should you remove the wrong file...just sayin'...

Best of luck :).
  • Like
Reactions: Mikestony
Upvote 0
Sorry, missed this one when it was first posted. You have a Desire (Bravo) that is rooted, but is it S-On or S-Off? To simply delete apps while running Android it needs to be S-Off (i.e. NAND security off - an extra protection on HTC devices).

Since system apps live in a separate partition you won't regain space by removing them. Clearing their data, uninstalling any updates and freezing them will have the same practical effect as uninstalling.

I don't know whether the S-Off tools are still available. They depend on software version, but for later versions revolutionary is the one you want (http://revolutionary.io if memory serves). But it's an old device and people don't maintain downloads forever.

If you have one of the less common CDMA Desires (some US networks) then best to check compatibility. Most tools and mods for the Desire were for the GSM version.
Last edited:
Upvote 0
Thanks everyone so much to process so little time, I've been off work now back so I'll try and pick this back up in a couple of days with all the suggestions.

Since system apps live in a separate partition you won't regain space by removing them.
Well I had read that, but my next step was to see if I could put stuff in the system partition or change the size of it
Last edited:
Upvote 0
The only way you can change the size of the system partition is flashing a custom hboot. Since hboot is a firmware element, as Hadron has said you need to gain s-off on HTC devices in order to gain full access to the system and other critical partitions.

Note playing about with partition layouts and firmware carries a real risk of terminally bricking the phone, just saying.

Before you do anything else I would recommend you install a custom recovery - 4EXT Recovery is what I'd recommend - and run a full nandroid backup.

Then I would read some of the excellent guides in the Desire sub-forum on here, everything you want is covered.

I still have my Desire and is what I cut my teeth on learning about this stuff. I even have most of the downloads covering some custom recoveries, the original AlphaRev s-off tool, custom hboots and so on. Shout if you can't find the tools referenced in the guides online.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.