• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Updating i7500, and now... a problem

Yesterday I put my phone on NPS and saw that there is an update. I was so happy and hit "Update" button fast.
After downloading, phone reset, boot starting but no desk apearing. Only "SAMSUNG" word flashing on screen. There was no reaction on buttons. Battery out and in, phone boot and same thing happens. Try updating again but NPS said that cannot recognize the phone. Recovery button is disabled.
After short browsing on this forum I saw some that there is combination of three buttons for turning on download mode. I try that and it works, but didnt do anything before thinking and some consulting here.

What are my options now? Personaly I would like to have official update, if not then roll back is good option, if not what can I do to hack my phone without loosing any too much options on my phone?

Unfortunatly, I did not write down old and new firmware code, rushing to have update fast. Phone is Europe model (Serbia).
Don't care for localisation, English is fine for me.

BTW, I said that button combination (Vol Down + Call + End Call) worked. It worked in a way that something shows on screen: Image of floppy with arrow and thats it. Somewhere in this forum i found that this combination should boot phone in recovery mode. Did I understand it correctly? If so, then I am in trouble.
Upvote 0
the floppy with an arrow screen means you're in download mode - you pressed ok, not call
here are the combinations: Galaxy Essentials - Android Wiki

download mode (floppy img) is where you wanna be when updating with odin, don't need to be in recovery at any point

of course you could see if you can fix your problem in recovery before flashing a new firmware with odin
Upvote 0
Last night I used ODIN to flash IK5 firmware after Galaxo and ended with Samsung title blinking.

Since I didnt do factory reset before flashing I used volume down+call+end call combination,

After that press home key and you are in restore mode, than select wipe data or factory settings...

After that IK5 booted with no problems.

Check here if you solved problem, Bye
Upvote 0
I used Galaxo but GPS performace was horrific. Maybe it was because baseband JB2 (first 1.6 release). Now I flashed IK5 (1.5) and GPS works without problem.

I will flash Galaxo again using IK5 ad baseband but I will wait wifi tether to be integrated.

P.S. Nije pristojno na engleskom forumu pricati nerazumljivo drugima.
P.S. It is not polite to speak in other language on english forum so others cannot understand.
Upvote 0
He was trying to be direct and make understanding more easy for me. :)

Now I am learning how to flash with Galaxo, looks like a bit different. Still not decide yet should I need to do it. Few Russian words left are not bugging me too much.

I am using this phone as developer platform, other then that are only several calls and few SMSs
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.