• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help upgrade crashed


Aug 7, 2011
I was trying to upgrade my ssg2 to the latest firmware using Kies it stopped upgrading at 3% I tried the emergency recovery but it fails to work. I get the message "failed to convert to upgrade mode".
The phone is unlocked on 02.
I would be grateful for any help Please.

Yes that is how you enter download mode. You press volume up to confirm that you wish to enter download mode.

So now that you can enter download mode it is possible to flash a firmware via Odin and salvage the phone.

Keep in mind though that improper flashing can brick the phone, so be very careful if you choose to flash it yourself. Also make sure that you only update to the Official formware for your phone so that your warranty is not voided and you are eligible for future updates via Kie or OTA
Upvote 0
Yeah, that power & home button shortcut didn't work for me...Otherwise, experiencing the same issues

I have an unlocked S2 that I was attempting to upgrade the firmware to ICS via Kies on a PC. Everything looked good bu at around 85% progress in the installation or downloading process of the update, it froze.

Stuck on the 'Firmware upgrade encountered an issue. Please select recovery mode in kies & try again.'

I can't get it to change from this screen and I can't upgrade or reset the phone. I attempted the reset with the hold, vol. down & power buttons pressed but it brought me to the rooting option screen. I could choose to root or reset but resetting brought be back to the frozen screen I mentioned. I've restarted the phone (removing battery) and kies but nothing works.

Am I only left with trying to root the device or can I somehow manage to get back on the upgrade track (Which I prefer)?

I've gathered from elsewhere that my best option is to flash the firmware...I have a Mac 10.6.8 and I saw somewhere that Heimdall supposedly works well in place of Odin...I downloaded what appeared to be the correct ICS firmware for my country and carrier although when I tried to have the md5 file load into the Heimdall program, I received an error message about it being malformed...Moreover, I am unclear as to how to locate the PIT file that is mentioned in the guide
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.