• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Where do the app file is downloaded to?

emaeo

Lurker
Jun 28, 2013
4
1
Hello guys

Android version: 2.2
No task killer app is used
Phone not rooted

Issue:

I had a 35 Mb free space internal memory, i tried to install an app (44 MB) from the market, but i have forced apps to be installed on the sd card without rooting (using some thread in this forum). Any way, while downloading the app, Google play shows that the zipped apk file was around 11 MB only, so it was successfully downloaded. But while installing, it showed an (Insufficient storage available) error and the installation was terminated.
The problem is that the free internal storage was reduced to 16 MB even the app was not installed. I tried to do the same process again, and now the internal memory is reduced to 11 MB

Where can I find the downloaded apk file, and can I delete it?

Please note that i tried clearing the cache using many apps (App 2 SD, Elixir, & History eraser). Also i tried rebooting the phone.

Fast response is highly appreciated

Thanks in advance
 
Thanks for the reply, but as I mentioned I have forced apps to be installed to the sd card (using some post in this forum). But I guess the apk zipped file is first downloaded to the phone memory before being installed to the sd card. So I am seeking of a way to delete that apk zipped file ( which failed to be installed, as I mentioned in the main post)
Hope i made my self clear
 
Upvote 0
@Android Player: That's for the S4, not the HTC Desire. Or were you posting from Tapatalk? That sometimes posts in a completely different thread from the one you were looking at ;)

@emaeo: If it's in internal memory rather than the cache partition then it's probably in the /data area, which on an unrooted phone you have no direct access to. The thing is, if you force install to sd that only moves the apk (apk plus lib when running 2.3). Other app components remain in internal storage, and that's why you've hit low memory.

It might not be the apk either - could be another app components (e.g. the .dex file - dalvik cache element, which will always be in /data), or some data file that the app downloaded. I'd look in /data/app or /data/data, but as I say, without root you can't do that.

The trouble is, if it is somewhere you can't see, and the app isn't installed (so can't be uninstalled), there might not be a fix other than a factory reset, which has the drawback of erasing everything.
 
  • Like
Reactions: emaeo
Upvote 0
Thanks for the help :)
The sentence which helped, is when you said:
"The trouble is, if it is somewhere you can't see, and the app isn't installed (so can't be uninstalled),..."
So I uninstalled some apps to free some actual space for the 44 mb to be installed. And then I uninstalled the app after correctly installing it. And then re-installed the app. And by comparing the free space before and after the re-installation, I got 5 more mb. So I guess its solved now.

Thanks again :)
 
  • Like
Reactions: Hadron
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones