• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Which custom ROM and what do I need? :/


Nov 6, 2010
Hey guys,

I rooted my phone recently, using z4root, and installed busybox and xRecovery 0.3 . I've tried quite a few times to install custom roms with no success.

I have:
2.1 update 1
band base 2.0.46
Kernel 2.6.29
Build number 2.0.A.0.504

Every time I've tried to install a custom ROM with xRecovery, after reboot my phone freezes at the SE text logo :/

Do I need to install anything else? What could I be doing wrong?

Cheers and thanks
Well guys, I think I screwed up one more time. this time SEUS wont repair the problem. I got to install the .435 version, but, now I dont have internet over the air... I mean edge, 3g, H.... nothing. everything else seems to be working fine. The phone in fact feels a lot faster, but no internet...

SEUS says that I have the lates software (which I don't) and won't give me the option to reinstall/repair. PC companion gave me the repair option, but stop in the middle of the process...

Any suggestions? :)

BTW...There's no Market app in the phone.

*UPDATE: My phone was a X10a....and I installed the .435 generic for X10i, I read it was not supposed to affect anything, but I had no market and no internet connection (3g, edge)... SEUS wouldn't let me repair. So I installed the generic .435 for X10a and I had market back but no 3G or Edge. At least SEUS is repairing it now...

Too bad I couldn't get the internet working because the phone was noticeably faster.

Upvote 0
Well, I ran SEUS and I re-installed software, but still no 3G. And I dont see the Operators logo or software anymore :)


Who is your Provider? You should be able to google "*provider* 3g settings" or head to their website and help section
and enter these on your phone in settings>wireless&networks>mobile networks>Access Point Name
and that should get it going. I had to do this after updateing to 2.2 Im on Virgin UK, so have the settings for them if you are also.
Upvote 0
Well, I ran SEUS and I re-installed software, but still no 3G. And I dont see the Operators logo or software anymore :)


Well, no because that stuff would be removed when you installed the new ROM.

The difference between X10A and X10I is the bandwidths they use for their 3G, H, etc. So that is probably why you are having the problems with it. I would suggest going to your provider's website looking up the APN settings on there and then manually inputting them to your phone and that should clear up the problem you are having.

Other than that, you could try installing the X10A version of the .435 ROM or the 2.1.1.A.0.6 ROM. Check here for more info:

X10i 2.1.A.0.435 & 2.1.1.A.0.6 for FlashTool - xda-developers
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.