• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root WHITE screen green htc logo after flashing N1 table

Hi guys,

Have tried to find a fix for my problem but not sure exactly what to do,.

I S-offed my phone using revolutionary and installed the MIUI rom, latest version available.

I kept getting the low memory warning so thought i'd flash the N1 table. So, using AlphaRev 1.8 as a guide, I installed the second BP99IMG.zip from the list onto my SD card, and then put it in my phone and entered HBOOT using power button and vol down key. The phone automatically starts updating the IMG zip and then asks me if i want to reboot, i say yes. Next thing the phone reboots but wont go past the white screen with green HTC logo?!

I can still enter the HBOOT but cant enter recovery cos it goes back to white screen. Any ideas?

Phone details:


Thanks in advance, Dash.
Even if the ROM would fit, you should take a nandroid before flashing a hboot and restore it afterwards. Moving all the partition boundaries will generally screw the current ROM+data up nicely. This is in alpharev's instructions.

I second SUroot's solution - either flash via fastboot or put the correct PB99IMG.zip onto your card, which will need a card reader if you can't get into recovery.

Not being able to enter recovery is disturbing though - I wouldn't expect that to be affected.
  • Like
Reactions: bigreenpants
Upvote 0
Im using the Revolutionary S-off and recovery tool 0.4pre4, is that wrong? I downloaded it from the second link under the GSM HTC OTA update URLS from:

[ROM] Official HTC Desire RUU ROMS and OTA Update URLs - xda-developers

Also tried:


But get below error code when trying to run it:

Error Code: -5001 : 0x80070002
Error Information:
>SetupNew\setup.cpp (142)
@Windows XP Service Pack 3 (2600)
IE Version: 8.0.6001.18702

Using windows XP
Upvote 0
Don't know, yet.

So let's make sure we understand the situation: you originally had S-Off, but had not changed hboot (i.e. had the stock one)? Then you flashed the N1 table, and it all went wrong. Nothing I've missed?

Now you have the stock hboot, so you should have the same partitions as previously. The hope was that with the partitions restored the data ("data" here includes the ROM) would be readable again and the phone would boot. But it still won't boot, so something's obviously been corrupted.

And then there's the bit that really worries me: you can't enter recovery. Is that still the case? Because if returning to the original hboot didn't fix it, our options from here on are going to involve recovery. Also I don't understand why you can't access recovery, because the hboot shouldn't affect that at all.

If you still can't get into recovery, I think we have 2 options. Either fastboot flash a new recovery, then see what we fix (do you have any nandroid backups, for example), or else roll everything back to stock using an RUU and start again.
  • Like
Reactions: bigreenpants
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.