• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Wireless glitch, both xtrROM and Kaos38


Aug 12, 2010
I noticed a glitch with my Eris' wireless. On any normal network, it works fine, but when I try to use a network where they redirect to a site to register/login (like at my school or Panera's) phone is unable to use the signal.

I always thought this was a glitch in xtrROM 4.6, but I recently flashed Kaosv38 and had the exact same issue.

Has anyone found a workaround for this?
T2, are you saying you can pull data from those networks without first, opening your browser and logging in? I'm currently running xtrROM 4.6 and I can't use these types of networks without logging in. I've also ran your rom, and had the same experience.

That's the way that many of those sites work - they will deny any network activity over their WiFi network until you authenticate and accept the terms of service using a browser.
Upvote 0
kaos is froyo but xtrrom is 2.1, and in both cases,i couldn't even get to the authentication page. when I turn off my 3g and only have wireless on, it just says there is no connection

T2, how did you get your wireless to work?

also mr williams, were you able to get to the authentication page? is your internet working?
Upvote 0
I thinl I may have misunderstood this topic. My skewl uses a wifi connection that needs to you to log in through browser after you connect. I just have to try to go to any page and i will get redirected to the schools authification page I log in then I get rredirected back to my original page. I use this metwork about every other day and have never had a problem with the d1or eris connecting. I figured that this problem might have been rom related because every rom/phone I have tried has no problem with this kind of authentification process. But I only used plainjane on the eris on my d1 I use a diff rom about everyday. Is this the problem you guys are having not being to use the internet after trying to authenticate through this process? If it isn't sorry to have given you false hopes.
Edit: I use dolphin if it makes a difference. Now that I think about it once I tried logging to the network through the stock browser on plainjane and it wouldn't get redirected to the login page, so if this is the problem you guys are having maybe try dolphin browser.
Upvote 0
Hey T2, thanks so much.

So I tried accessing the wireless at my school with the stock browser. I have always used Opera. Using stock, I was able to get to the authentication page, and sign in, and now wireless works (except not on Opera, other internet requiring programs work though, google talk, gmail) I guess it was a problem with the browser. Hope this helps people.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.