• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Bricked S2 (I think) Please, I require assistance.


Oct 4, 2011
Hello, my name is Catalin (even the username says differently) and I have bricked an S2 GT-i9100 bought from an online store called eMag from Romania two years ago.

I tried to upgrade from stock 2.3.5 gingerbread to jelly bean following some tutorials on the internet, seemed easy.

First I had to root it since it wasn't rooted and got it to brick, I took a online file CF something and using Odin tried to root it, the result? it doesn't open anymore, I get to the starting screen and get the default thing for rooted (the triangle with an exclamation mark) then it restarts doing the same thing over and over again.

I am not a pro in this and this is why I require your kindest support and help for the dumb ones, I don't know what PDA file (rom firmware to use) what to do exactly to find it correctly, I'm not a noob in computers, I'm a noob in phones and ROMs mostly.

I can go in download mode, recovery mode (wiped cache and did a factory reset, but no succes), Kies would not recognize it, it gets blocked at "connecting" screen, which I find deeply infuriating, since I'm all out of ideas, I have read, and tried 100 different solutions, including upgrading to 10 different ROMs, following a tons of "tutorials" (people should be banned for trying to make a tutorial on youtube, some of them deserve to be crushed with many rocks, but then again I'm just awfully pissed right now).

Sorry if I posted on the wrong place (section), thank you in advance and I am begging someone to please help me, If you require more informations just tell me, I'm doing everything I can do)


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.