• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Help erased all data on rooted evo!!!!


Jun 26, 2013
Ok so I rooted my HTC EVO 4G and it worked well. So I bought a new phone and I wanted to sell the EVO. So I factory reset the phone and erased all of the SD CARD data and now the phone wont turn on. I push the power button and it takes me straight to the bootloader screen and when I click reboot, it goes right back to the bootloader screen.
Please help I have tried everything!

Hboot 2.18
Hello there bitw12345! :D
It seems you have relocked your bootloader somehow. :thinking:
Did you flash anything besides the factory reset and sd card wipe?

The reason I ask, is when folks root the Evo, the bootloader needs to be unlocked.
It usually doesn't relock itself from a simple factory reset or sd card wipe.

Perhaps did you flash a PC36img .zip file?

From here tho, I we can move your thread into the Evo forums here:
EVO 4G - All Things Root - Android Forums
or, if you prefer, you can post over there for more help too:)
  • Like
Reactions: ocnbrze
Upvote 0
  • Like
Reactions: bitw12345
Upvote 0
Well, perhaps I am wrong about the usb debugging setting.
The fastboot setting won't be able to be changed either but just pull your battery and reinsert to access bootloader like you have done.
Then follow the HTC dev method to unlock the bootloader.
Once that is done we'll install a recovery as outlined in Step 2 of the guide I linked.

You've rooted before you said so perhaps this isn't all new to you ;)
  • Like
Reactions: bitw12345
Upvote 0
I have already tried to unlock it using the htc dev method but when I try to get the identifier token, it keeps saying waiting for device. And when I first rooted I remembered I turn on USB debugging
Well, that's what I thought too...it's been a while, but according to the guide I linked and the instructions at the Dev site, it makes no mention of the usb debugging.

As far as the "waiting for device", does the words "fastboot" change to "fastboot-usb" when you plug it into the computer?
Upvote 0
hmmmm.... do you have another cord to try or another usb port to try?

I assume you have the drivers installed? Make sure that there isn't any other program trying to connect with the device automatically when it is plugged in.

Try this, when you are in fastboot and you have the command window open, type in:
fastboot devices
and see if anything comes up.
Upvote 0
No, just open up the command window at your Android folder (in that folder you should have the files :


kind of like this:
I blocked out my ID there.:)
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.