• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Help With phone stuck in fastboot

So full information. I have a Motorola G7. Last night while it was on its charging dock, the cable got unplugged and the battery died. I have had it on the charger all morning, but no matter what i do (tried rebooting from recovery, using the options in fast-boot to reboot it, hard reboot with power button) when i try to boot the phone up it sits on the splash screen for a few moments, then goes dark and returns me to the fast-boot screen. It absolutely will not boot android up. Ive never had issues rebooting the phone or anything along these lines. Ive even tried using the fast-boot commands to reboot it and it still just immediately returns to the fast-boot screen on the phone. Any one know a method i can use to get it out of this apparent bootloop?

The information at the bottom of the fast-boot screen is as follows for anyone needing it. Thank you in advance for any help. I'm by no means a newbie when it comes to android but ive never encountered this specific error and have found nothing but useless information when trying to research it.

Ap Fastboot Flash Mode (Secure)
BL: MBM-2.1-river_retail-0ff20295b20-200404
Baseband: M632_26. River_NA_CUST
Product/Variant: river XT1963-1 64GB PVT
Console [NULL]: null
Tools Mode Config: Disabled
Battery OK {Charging]
Connect USB data cable
looks like you might need to flash a firmware update. but i am having trouble locating one specifically for your device. make sure it is for XT1963-1, but i googled it and found nothing.

not sure what else you can do at this point without the ability to flash a firmware update.

I actually mistyped that info apparently. Its a 1962-1 not 1963

But i was of the same mind. I decided maybe something broke on my rom. I DID have a custom boot animation so my idea was gonna be to reflash the stock rom. I however could not find the stock rom except on some pretty shady sites. ended up saying screw it and installing LineageOS

So far it seems to have fixed it. Phone boots, ive installed gapps, and am currently working on reinstalling all my apps. Ill leave this thread here for anyone else who may run into a problem in the future. I appreciate your attempt to help though, and you had the right solution it seems lol
  • Like
Reactions: ocnbrze
Upvote 0
Ok so the main issue would have been if you flashed a stock rom it would have most likely un-rooted your phone...... Not sure but I think so, never owned a moto phone before.

Glad you are up and running though.

It would have replaced my stock recovery, but i would just have to boot it using adb and then reflash the custom recovery. Honestly im actually liking the lineage os better than the old stock rom. only reason i hadnt flashed it sooner was due to not wanting to lose all my data lol
  • Like
Reactions: ocnbrze
Upvote 0
You, running 18.1 and it is the android 11 implementation. Previously I was still in android 9 as I rooted this device literally the day I got it, and while Motorola is fine with unlocking their phones for you, they disable your updates when they do.

I'm liking it so far. Clean and easy to use. Only thing I'm not liking is the change to FB messenger chat heads but that's an android thing so just something I gotta get used to
  • Like
Reactions: ocnbrze and svim
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.