• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root How to take Motorola Photon 4g out of the grave?


Aug 23, 2012
Recently I ordered Motorola 4g from US.... It was with stock Sprint Sunfire OS.

System Version : 45.4.13.MB855.Sprint.en.Us
Model MB855
Android 2.3.5
Baseband N_01.29.10R
Webtop 1.2.0-180
Kernel #2
Build 4.5.1A-1_SUN-254_13

NOW ITS DEAD.... running in RSD Mode

So what I did, I was trying to install custom rom on that. Steps I had taken

  • Rooted phone via installing SuperUser and various rooting methods like ClickOnce, Photon -Torpedo but no one seems successful , while executing I got errors everytime. But after day or two I came to know about that my phone is rooted. As I was getting SuperUser popups on root operations. Then I installed CWM and tried to install the ROM from there but everytime I got stucked at Yellow Triangular icon (recovery mode).

  • Repeated step one, rooting process and unlocking the bootloader by applying pudding.rar and fastboot commands and every time i got the error and Starting RSD Screens, but anyhow my phone recovers itself to its original boot state afetr pulling out battery and manually restrating.

  • Finally one day I use some other Recovery Tool , i am unable to recall the name. It installed and rebooted successfully in the recovery mode. I then wipe the dalvik cache, wipe factory reset and then tried to installl the custom rom that MIUI 2.68 i think . I was happy to see some designer screens on my phone and then it said rom installed successfully.

I then reboot my phone and found it in the Failed To Start2 , Starting RSD mode

I tried various way to restore...

Installing pudding.rar using RSD lite but everytime I got sec_exception : sec_exception : b655, eddc,eb
I then tried reinstalling SBF : 1FF-sunfire-user-2.3.4-4.5.1A-1_SUN-198_7-CM-release-keys-signed-Sprint-US.sbf and sunfire-2.3.5-4.5.1A-1_SUN-254_4 but while enumerating phone I got error sec_exception febe 4e 4e
I have also tried nopudding4u.sbf but the same result.

Please,, help me and my phone out .. as its going to be more than a week... i feel handicaaped...

Please guide me through the step by step , which file and when and please do provide the links of the files to download.

**Update OTA with 2.3.5 before murdering.....**
To be honest, you might have better luck getting step-by-step instructions on how to fix this issue by checking out the Photon forum on XDA. That said, as far as I know you can not unlock the bootloader on the 2.3.5 build; the update closed the exploit used to do so. You can install "locked" ROMs using a bootstrap method, and you might be able to flash a stock SBF the same way to fix your problem.

Anyway, check the various threads in the Android Development section, and if they don't help then try posting in the Q&A section. Hopefully someone there can give you detailed help on solving your problem. Good luck!
  • Like
Reactions: amitranjan
Upvote 0
I have been in XDA already. Asked the same question there too. But no reply from the devs. If you can guide me how can I restore my phone back then it would be great help..... I feel handicapped , bro :(:(:(:(

Also , I want to know ,

1. do my phone have its original stock files or i have to fix all the files
2. Can I install custom rom further i have to remain on the locked one.
3. My phone is from USA and I am using this in INDIA, am I able to use the phone here , or do I need to perform a SIM unlock too...
4. or,U want to say Locked means the locked bootloader not the locked GSM radio.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.