• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root need help =( 3g painstakingly slow


Aug 12, 2010
I have been having issues with my 3g for the past couple months, almost to the point where I can't use it anymore. I run the Ookla speed test app, and no matter where I am, max I will get is around 200 kbits /sec. (in Boston I think the average is around 800.)

I had been rooted running apex rc4, but alot if the problems seem to have started when I switched over to try the new MIUI. since then, I have sbfed back to 605 stock and bot running any roms, just stock

I know I have an issue with my nvs_map file because my mac address keeps getting spoofed, and I'm currently trying to get that fixed. Unfortunately, I don't know if that is affecting my 3g or if this is a whole separate issue. Any insight or help would be greatly appreciated

( also, I don't believe I'm being "optimized" by Verizon, my data usage isn't that high and had a rep tell me as well
Thanks for the input. Yeah, sometimes I get that sneaking suspicion too, also that they want me off my unlimited plan *paranoia*. Fortunately for me, my phone really hasn't been pushing the .621 update (maybe because the 3G is so slow it couldn't even handle the OTA, haha) but I have tried factory resetting and SBFing before to no avail =(
Upvote 0
ahh, I got really excited for a moment, I completely forgot about my backups, and even though I've deleted the older ones on my phone, I still have an older folder on my desktop which I haven't really touched.... or so I thought, I updated my desktop folder not too long ago and unfortunately there were no more backups, bummer
Upvote 0
How about this: create a backup in recovery and Titanium Backup, making sure it's successful. Then factory reset, reboot.

Activate it, open Market, cancel update downloads and install your speedtest app.

If it isn't any better, restore your recovery backup and you won't be out anything, but a little time.

If the problems resolved, open TIBU, press menu, choose "batch", and restore missing apps + data. Do not install any system or user data (red/green items).
Upvote 0
haha yeah, a couple times, didn't really help too much. If other people don't have this problem, I'm hoping it has something to do with my NVS file, and maybe it'll fix itself after that. I've tried blackadept's fix on Rootzwiki, but my phone doesnt seem to like that either. Thanks for your help and quick responses though =)
Upvote 0
  • Like
Reactions: APCharlie
Upvote 0
I gave this a shot... My first attempt at runnign a script, and despite reading directions both here and after the links and following them to a 't' I keep getting the same errors...

line 4: syntax error: enexpected word (expecting "do")

I look at line 4, and there is clearly a "do" already there...................... I really hate syntax errors. Is there something I might be doing wrong?
I'm already on busybox 18.2 as suggested......
Upvote 0
There were 3 links to files on that page.... one was for V6 (which I've used), one was for the 3G fix (which I've never needed). Just make sure you get the correct one and use "SU" (superuser) option when you run it. I doubt the busybox version is that important as long as it's the full version. I use busybox installer from Market.

I right-click on the file to save the link to my computer, then copy to Dropbox, which I use to send to all my devices. You can also just mount your phone via usb and copy the file over, whatever works.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.