• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help No data after yesterdays update on galaxy s2

The thread title reads no Date after ICS, did you by any chance miss-spell data?
If yes then please ask the moderators to change the thread title, it's a bit confusing.

About your problem, thesmellyone is probably right.
You can manually enter the APN settings that are required. go to giffgaff's site and check to see what the APN settings are and then enter it manually.

Long press the power button and on the pop up menu that comes ensure that Data network mode is activated.
Upvote 0
I had the same problem after an update this morning (11/5/12).

After trying, and failing, with all the logical fixes, this worked for me:
- Turn off "3D data" in the Mobile network settings
- Restart the phone
- Turn the "3D data" back on.

I didn't expect it to work, but it did! Weeee!


Er...maybe I was too quick on that solution; I turned off my Wi-Fi to see if the phone would properly switch to 3G. It did the first two times I tried it, but not the third. I just love consistency in computers...

Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.