• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Rooting GT-S5839i says E: cant mount /sdcard


Nov 7, 2015
I have downloaded root.zip file and copied it to my SD card. When I boot in recovery mode and try to apply the update I get the error message "E: cant mount /sdcard".

There are several solutions to this problem but I've seen none which are specific to my phone model (Samsung Galaxy Ace GT-S5839i) and OS (Mac OSX 10.8.5).

I want to root the phone so that I can move apps to the SD card becuase the internal memory is so small it's barely able to hold more than a few before running out of space.

How to I fix this mounting issue with the phone? Help.
Last edited:
What is the Android version?
If it's still 2.3.6- 4.1.2 than Cydia impactor for Mac should work. Run it and if you get no errors install SuperSU.

As far as the SD card not mounting it could be alot of different things, hard to say from here.

Thanks James,

It's Android 2.3.6. I'll try Cydia and SuperSU.

The mounting issue was due to the SD format not being recognised by the phone. I reformatted the SD card using SDFormatter and than seems to have solved the "E: cant mount /sdcard" error message. I can now browse files after selecting "apply update from sdcard" but when selecting the root.zip file I get:

E: Can't open /tmp/sideload/package.zip
Installation Aborted

So not solved this yet.
Upvote 0
I've downloaded Cydia Impactor but don't know what to do with it. When I run it I'm presented with a drop down box containing various options the first and default one being:
# drop SuperSU su to /system/xbin/su

Clicking start shows error message "no device found".

I'm pretty lay when it comes to this. Can you explain what both downloads are meant to do and how I should use them.
Upvote 0
Do you have Kies for Mac installed? Probably not since your getting the no device found. Enable USB debugging on the phone. Settings, applications, development then enable USB debugging.

Download Kies for Mac from here. http://www.samsung.com/in/support/usefulsoftware/KIES/
Run the install and then reboot the Mac. Then the drivers should be fine.

Open impactor and press start, if you get no errors you're good to go.
Last edited:
Upvote 0
I didn't have Kies installed.

I just enabled USB debugging on the phone. I downloaded Kies for Mac OS and plugged the phone in after It installed. The phone was recognised by Kies so I opened Impactor and pressed start. Impactor seemed to do something this time, it displayed "installing package" briefly before an error message occured: "INSTALL_FAILED_INVALID_APK".
Upvote 0
I got the root.zip from http://forum.xda-developers.com/showthread.php?t=1642895. Post #7 has it linked with a description for GT-S5839i which is the same model phone as mine.

Just checked, the file extension is still .zip (root.zip).

I used SDFormatter. Mac version available from https://www.sdcard.org/downloads/formatter_4/eula_mac/index.html.
It didn't specify which format it would reformatted to I just selected complete format which seemed to get me past the initial problem with the card not mounting.
In disk utility the SD card is listed as MS-DOS FAT16 (see my upload of screenshot).

Let me know if this helps.


  • Screen Shot 2015-11-10 at 03.35.31.png
    Screen Shot 2015-11-10 at 03.35.31.png
    39.2 KB · Views: 121
Upvote 0
It could be ok i guess to use fat 16, i'm more used to seeing it as fat32. Does the phone have an option to format the SD when you go to storage?

Trying to think as the last time i seen one of these devices was quite some time ago and the person was in Africa.
Do you have anyone in your household with a SD card you can use to eliminate it being the SD card itself?
Have you tried this instead?

I have a couple more ideas as far as apps.
This was a popular PC tool but now is in apk/app format.


Last but not least rootmaster app or maybe Kingroot. I'm unsure if Kingroot works on 2.3.6 but i do know Kingo root supported 2.3.6
Upvote 0
Thanks, I tried the http://forum.xda-developers.com/showthread.php?t=1891162 link and downloaded both the files.

I managed to get the phone to apply the update in recovery mode from the root.zip but then when it completes and I reboot the phone I am still not given root privileges. Moving apps to SD from phone internal phone memory is still not possible (which I think is possible if you have root access).
Kingo Root is also listing me as Not Rooted. The rooting function also fails each time I attempt to root through the app.

I thought I had it when the phone seemingly successfully applied the root.zip and CWM_5839i.zip but I guess not. What a stubborn problem.

Any more ideas?
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.