• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Settings has stopped storage error??


Dec 26, 2013
Hi there, I am new to this forum so if this is the incorrect place to do this I apologize.

I have a coby kyros 7035. About 2 weeks ago it started giving me an error every time I tried to click on an app saying it isn't installed. When I would check my storage in settings to make sure my card was still mounted it would say unfortunately settings has stopped and exit out of settings. I can go anywhere else in settings but storage. I can't read anything on my sd card from the tablet. I put it in my pc and can read everything fine from that. I tried next to plug my usb cord from my tablet into my pc and I get a never ending circle as if saying it's thinking about it, never actually doing it. After a few days of getting frustrated and not really finding a fix online anywhere I finally decided to bite the bullet and do a full factory reset. Well, I did that and I'm still getting the error. It's not the sd card. I'm really not sure where else to go with this. If anyone can help me I would be greatly appreciative.
Hello Heather, welcome to AF.

If you're certain the SD card is OK, like the content works on your PC, things like photos, videos and music plays OK. You could try reformatting the SD just to be sure that the file system has no issues. Backup anything important first though.

Hi Mike,

I was able to play the movies and such on the sd from my computer so I copied it all to my desktop and reformatted the disk. I put it back in and, same problem. I think it's some sort of internal error because even when the card isn't in it I still can't access the storage file in settings.

Any other ideas???
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.