• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Updated, WiFi Screwed...

Just got this phone today, brand new. Played with it about an hour then it popped up saying there was a system update, let it do that, did a full reset because apps were acting funny also, then everything seemed to run smooth. Got all my apps installed, data moved over, etc...

Was working great until i turned on wifi. It connects right away to my router, my router is only a few months old, latest firmware, its a N class router, everything else in the house, phones, laptops, roku's, kindles, etc, they all work just fine.

It shows its connected, the wifi symbol is blue, but when you try to do something data related it just sits there like its waiting for data. If your in chrome it just sits there with the loading bar at about 25%, sometimes you can wait and after say 3-5 mins it will finish loading the page, other times it don't do squat.

I have tried everything i can find online, turning off the weak signal setting, even though i am about ten feet from the router, i deleted and then added back the access point in the list. I have changed settings in my router, its WPA2 right now, i tried WPA, WEP, and even wide open. The phone still randomly just stops loading stuff. If i shut off the wifi and go back to 4g then everything is back to normal. Problem is i need wifi to work on this thing or its useless to me. There is no 4g signal in many places i end up, though there is wifi available to supplement it.

I called Verizon they said upgrade your router.. I was like my router is only a few months old. They said reboot it, i said no everything else is working fine, although i did end up rebooting it for the heck of it. They said upgrade the firmware, its the latest firmware available. The other phones in the house along with friends that come and go, HTC Incredible, HTC Rezound, Galaxy S3, LG Spectrum 2, none of them have any problems and will stay on wifi indefinitely.

The wifi symbol on this Razr M will go from blue to gray every few mins, and their is an arrow symbol in the center of the wifi signal indicator. The arrow shows up it turns blue again, then it turns back to gray and the arrow disappears. You can't web browser regardless of it being blue or gray, it starts to go and then stops.

Any suggestions??
It would appear it doesnt like AES, i set the type to auto in my router so each device can choose and now its staying connected so far. Will do some web browsing for a while and see if it keeps working.

If you have a TP-Link Wireless N router or AP you will have to set Version and Encryption to Automatic after selecting WPA/WPA2 Personal in Wireless Security.

Will update after a while and let you know if its still working. I have a few other routers that i generally use during a day, will see if it works on them as well.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.