• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root help!


Jul 8, 2013
Hey guy's!
The story...
I was continually unable to update my "preferred" software, due to bloatware I never have used in the two years+ I've owned my EVO 4G. I had some time so I looked into rooting. (Through Titanium reviews)
I came across Unrevoked, tried it it failed. Research said it was missing files... I found a intelligent guy that sounded like he knew what he was doing. Got it rooted. The following step to flash roms failed. His advice, try another SD card. Which I have now but didn't at the time. He/I should have did a Nandroid b/u. But I was unaware. I should have know better. Further research led me to Rom manager. Which I downloaded and installed. The same source recommended Cyanogen, looked fast! Sounded easy. First attempt failed. My phone was in a load to Sprint loop. Somehow I redid the root process and was able to get out of it. I installed titanium. Downloaded all my apps and went at "uninstalling" instead of freezing! Kindle, Nascar, Flicker, Sprint TV, Twitter (Peep)... as I went up the list from the bottom I regrettably uninstalled phone! My contract is up and don't have Sprint service. So, I figured I didn't need "the phone" OOPS! I kept getting enter your timezone even though the time was right! Every 5 minutes! (BOO BOO) Second attempt to install Cyanogen I fell asleep and woke to the blue Android on the skateboard load screen but it wouldn't respond to any prompts.
Now, no Nandroid backups although I have other pre-root backups on my PC. I can get to boot loader. I have no idea if debug is on. I can't get to anything but the boot loader for the loop on the Sprint logo is back.
I tried wiping Daviz, data... everything but the SD card. Nothing. I then tried RUU got 155 error? I have RUU_SuperSonic_GB_Sprint_WWE_4.24.651.1_Radio_2.
and RUU_SuperSonic_S_Sprint_WWE_3.70.651.1_Radio_2.
All I remember about my phones info is it was software was newer than 4.67 I wanna say 5. ...? And HBOOT 2.18.

At this point I'm not interested in roms! I have no idea what went wrong. I'd like to get back to factory and root! P.L.E.A.S.E.!
I added the guy that told me how on Google but he's not responding? I am going to be homeless and outta work in a couple weeks and would really like to have my phone available for wifi. Thanks for listening and your help!
First, welcome to the Forum! ;)

I'm a bit removed from the OGEvo so I'm dealing from memory here, but it appears you're most of the way there. At this point, the easiest way to proceed would be to flash a new rom via recovery.

Stock rooted rom- http://forum.xda-developers.com/showthread.php?t=1671395

download the rom and copy it to the root directory of your sd card. Boot to recovery -maybe a option in boot menu of Cyanogen by holding the power button? if not, from power off, press power+ volume down and then choose recovery. In recovery (don't know which you have) choose wipe and do a system reset,wipe the cache and dalvik cache (it's a good idea to wipe everything but sd card, but will leave you with a non booting phone should the flash fail for any reason) after wipe, choose install and then select the rom file you copied to your sd card. After the rom is flashed follow the prompts to reboot to system and you should have a rooted stock rom. Good luck!
  • Like
Reactions: bobaroo and ocnbrze
Upvote 0
also do not use rom manager!!!!!!!!!

i have seen waaaaaaaaaaaay to many issues like this from using it. also once we get you a working phone, i would ditch cwm as your recivery as well. there are waaaay better ones then cwm for the og evo.

i'm glad you found us even though it is a bit late. try what pasta above suggested. if you need help let us know.

good luck
  • Like
Reactions: bobaroo and tube517
Upvote 0
wiped cache, and dalvik.flas zip from sd card.
"install : 5.07.651.6_stock_rooted_deodexed_CPTB.zip?
Press Power to confirm"
Install from sdcard...
Finding update package...
Opening update package...
e:Can't open /sdcard/5.07.651.6_stock_rooted_deodexed_CPTB.zip
Installation aborted."
Upvote 0
I'm not sure what you meant by reset phone? I didn't see an option for it.It did say after formatting dalvik-cache that it was skipping format SDEXT:dalvik cache?

pasta means that you should wipe system, data, dalvik cache, and cache before flashing a rom. there is no reset.

and that message is normal as you probably do not have your sd card partition so i would not worry about it.

like i said it is probably a bad download.....re-download it and try again.
  • Like
Reactions: bobaroo
Upvote 0
ok so go here:http://androidforums.com/evo-4g-all...ooting-dummies-guide-gingerbread-edition.html

in the after root section there is info on how to switch recoveries.....just skip the root process.

and as long as the sd card is not a 2g card you should be fine with most other sd cards. it does not have to be the stock version of it.

and yes make a nandroid backup when you get a chance....though i would recommend that you switch to amon ra2.3. but the cwm nandroid will not work with amon ra
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.