• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Problems With ROMs after Factory Reset HALP


Jun 13, 2010
So I have the LG Optimus V and was running a custom Stock ROM. I was going to give it to a friend to use so decided to use the factory reset in the phone...whoops.

I'm using ClockworkMod Recovery v3.2.0.0 and every time I try to install a ROM from the zip file on it it just goes back to Clockwork after a reboot.

I've tried using the ROMs listed here: http://forum.xda-developers.com/wiki/LG_Optimus_V/ROMs (besides MIUIv4 and LeWa Port) to no avail. I just keep rebooting back into recovery after it says it was a successful install.

I've also tried getting into a workaround using fastboot but I believe the condition my phone is in right now won't allow it. I can't boot up to the fastboot recovery and other issues have arised.

So is there anything I can do or am I boned?

Thanks for reading and any feedback
Is your recovery still functional?
If yes, go to the All Things Root Guide sticky. Download the Canibal Open Touch recovery (if hard to find in zip form try ZenGarden) in it's zip form not img form. Put the zip on the sd card. Go to the recovery. Flash the recovery zip just like a ROM, only don't wipe anything. Then go to the advanced section and choose the "reboot recovery" option. It should now boot into that recovery. Can't remember where the fix recovery loop option is, but it's in there. Select it. Now wipe everything but the sd card and flash a Froyo ROM (it will, have the activate app). Make a backup of that ROM in the recovery.
Let me know how it goes. If know go, more options still.

Remember to tell the new owner never to do a factory restore from the phones settings, only use the option in the revovery.
Upvote 0
Thanks for the reply! Sorry about posting in the wrong place. I'll keep that in mind next time.

I was able to get the new recovery and opted for ZenGarden Though that worked just fine I'm still having the same issue where after a ROM install it just reboots back to the recovery.

I was able to find the boot loop fix and ran that. I then made sure to use the 'Wipe for new install' command each time and used 'Install and Reboot' but it's still rebooting into the recovery.

Any other solutions I should explore?
  • Like
Reactions: scary alien
Upvote 0
What rom are you trying to install and did you put the file on the root of your sdcard, also if the rom needs gapps, put that file on the root of your sdcard, not in any folders.

I would try to go back in the section of zengarden to fix the bootloop, then reboot system, do the wipe options again, then install manually the. zip of the rom, it should boot into the new rom, then install gapps and reboot, if the rom needs gapps installed.
  • Like
Reactions: scary alien
Upvote 0
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.