• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

KitKat upgrade problem Nexus 7 2013


Android Question

I have a Nexus 7 2013 wi-fi running Android 4.3. Every few days I recieve a 'new software downloaded' message indicating that 4.4 Kitkat is ready to install. Each time I have tried to install this OTA upgrade, I get the same problem. I follow the on screen instruction to restart the device and the installation begins. After a short while, the dead android appears with an 'error' message below. The only way out is for me to hold the power button until the tablet powers off. Then I can reboot and the Nexus comes to life still running Jellybean. The last time I did this I tried going into the boot loader menu where I noticed something about cache partition which I didn't quite understand. Do I need to clear the cache memory in order for the installation to work?
I also tried side loading KitKat but came across various issues including not finding USB drivers (eventually solved) and my Nexus not being seen by my computer when in boot loader menu.
I would prefer to upgrade OTA, so any help would be great!


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.